Follow

Browser Compatibility

Purchase Manager runs on the latest two versions of Internet Explorer, Firefox, Chrome, and Safari. Listed below are the compatible versions as of January 2017—this will update, and you must check to verify browser versions as they become available.

 

 

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request
Powered by Zendesk